博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
zju 1002 zoj 1002
阅读量:4121 次
发布时间:2019-05-25

本文共 3022 字,大约阅读时间需要 10 分钟。

Fire Net

Time Limit: 2 Seconds     
Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses islegal provided that no two blockhouses are on the samehorizontal row or vertical column in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integernthat is the size of the city;n will be at most 4. The next nlines each describe one row of the map, with a '.' indicating anopen space and an uppercase 'X' indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4.X......XX......2XX.X3.X.X.X.X.3....XX.XX4................0

Sample output:

51524

回溯法做的,不过我听说好像用贪心也可以AC,有兴趣的可以试试

#include<stdio.h>
char maze[4][4];
int most,now,n;
int backtrack(int x,int y){
    if(x==n){
        if(now>most){
            most=now;
        }
        return 0;
    }
    int i,flag=0;
    if(maze[x][y]=='.'){
        for(i=x;i<n;i++){
            if(maze[i][y]=='X') break;
            if(maze[i][y]=='#') flag=1;
        }
        for(i=x;i>=0;i--){
            if(maze[i][y]=='X') break;
            if(maze[i][y]=='#') flag=1;
        }
        for(i=y;i<n;i++){
            if(maze[x][i]=='X') break;
            if(maze[x][i]=='#') flag=1;
        }
        for(i=y;i>=0;i--){
            if(maze[x][i]=='X') break;
            if(maze[x][i]=='#') flag=1;
        }
        if(!flag){
            maze[x][y]='#';
            now++;
            if(y+1>=n) backtrack(x+1,0);
            else backtrack(x,y+1);
            now--;
            maze[x][y]='.';
        }
    }
    if(y+1>=n) backtrack(x+1,0);
    else backtrack(x,y+1);
}
int main(){
    int i;
    while(scanf("%d",&n),n){
        most=0,now=0;
        for(i=0;i<n;i++){
            scanf("%s",maze[i]);
        }
        backtrack(0,0);
        printf("%d\n",most);
    }
    return 0;
}

转载地址:http://axtpi.baihongyu.com/

你可能感兴趣的文章
Java线程知识深入解析(1)
查看>>
Java线程知识深入解析(2)
查看>>
RUP软件开发设计模式
查看>>
十条不错的编程观点
查看>>
惹恼程序员的十件事
查看>>
Java 线程编程中的同步、重复、定时
查看>>
数据库 SQLServer2005 中将一个表中从未重复的项筛选出来、去除重复项,只要一条...
查看>>
Java WEB开发时struts标签 显示set内容
查看>>
JavaWEB开发中用到DWR时的配置、调用、Form提交的方法
查看>>
JS 双人小游戏
查看>>
JS 字符串函数
查看>>
JavaWEB开发时FCKeditor类似office界面的ajax框架,加入后就能做界面类似office,能进行简单的文本编辑操作+配置手册...
查看>>
Java 开发中用到的几种过滤器
查看>>
JS 实现图层模式覆盖效果
查看>>
JS 页面控件的操作、以及页面在一段时间内不操作就跳转、页面事件列表
查看>>
properties文件读写 自己写的几个方法
查看>>
Java 对xml文件的读写操作
查看>>
JS 跟随光标的提示框
查看>>
SQLServer2005 判断数据库中是否存在某张表或是查找库中的所有表名,然后删除...
查看>>
JS 横向图片跑马灯效果
查看>>